Register.com - delay in Web site activation - poor service experience

Posted on Saturday, November 23rd, 2002 at 12:00am CST by d0e85968

Company: Register.com - delay in Web site activation - poor service experience

Category: Other

Complaints.com received the following consumer message on November 21, 2002:

From:

RE: Register.com - delay in Web site activation - poor service experience

Re; Register.Com This company has made promises concerning a website domain and activation,that I purchased, that they have failed to keep. I purchased the domain, then they advise me I need to fax verification documents for billing, which I did. They said after they received them, my site would be activated within 72 hours. Then after faxing I hear nothing, so I call them. They tell me the fax wasn't received and to fax to another number. So I did.So I called immediately, and they told me it had arrived. And again they advised, it would be up and running. I had ordered the site and was promised that it would be up and running within 72 hours. They made this promise on Nov 18,2002.And today I call them and they said they would email me a confirmation, which they did. So I checked the site and it was up momentarily. Then it was down. I called them AGAIN, and they told me I have to wait another 72 hours. Can you believe these people!??? On top of this, I paid for domain submission to search engines, that I know won't pick it up because of the lengthy time it has been down. In addition to this, the site has been nearly a week, and they want to charge me a full months service fee, rather than pro-rate it, as that would seem the fair thing to do, given the time it's been down. They still have not activated it. I have called them and they advised me to keep waiting. This seems very dishonest to make a promised then not keep it! I would NEVER recommend this company to anyone.


0 Comments

Post a Comment