1999 Chevy blazer radiator - 53,000 miles and sludge and mud in the radiator

Posted on Saturday, February 2nd, 2002 at 12:00am CST by 689f5b0a

Company: 1999 Chevy blazer radiator - 53,000 miles and sludge and mud in the radiator

Category: Other

# 11 for February 2, 2002

Complaints.com received the following e-message on February 1, 2002:

From: mike iroc [COMPLAINTS.COM_FORM_MAIL_21580#]

1999 Chevy blazer radiator - 53,000 miles and sludge and mud in the radiator

my 99 blazer with 53000 miles and its' 100000 mile antifreeze are not seeing eye to eye....sludge...mud ...3 hours of backflushing and still coming up with large flakes of i don't know what...

acording to the 2 dealers i spoke to the problem could be anything but the antifreeze itself and acording to gm's 800 number the 100000mile interval is "only a suggested interval" that can be affected by many variables...

that is not stated in their sales pitches,brochures,etc.i,m so discouraged by their unwillingness to accept that they blew it with the 100000mile claim that i intend to "return" their GM card rebate points and try my luck with an import next go around....

i've owned chevys for 20 years and this decision was not easy.


1 Comment

cacc5ea1, 2008-10-26, 10:28AM CDT

My 1998 Jimmy did the same thing right after the warranty went out, about 50,000 miles.

A rust colored brown sludge built up in the radiator, visible under the radiator cap.

I paid for a new heater core and labor.

It continued to run cold.

It did it again.

More sludge under the radiator cap and brown coolant.

I paid for a new radiator and labor.

This problem cost me out of pocket several thousand dollars.

It was the wax from the thermostat that got into the coolant system. The thermostat was stuck wide open.

The thermostats are faulty and I think a class action law suit should be brought against GMC for using faulty parts.

A very unhappy customer!

Ron

Post a Comment